+ Reply to Thread
Results 1 to 7 of 7

Thread: Tail light help please

  1. #1
    Junior Member
    Join Date
    Jul 2012
    Location
    Hampton
    Posts
    5

    Tail light help please

    Hi,

    I just got done installing new interior and in the process i had the whole dash out of my 65 convertible. When I re-assembled i believe all was good but recently the rear tail lights stay on and i can't figure out why. Its the running lights and rear only. Directionals work, brake lights work,but i can't shut off the tail lights without unplugging the feed from the brake light switch. I thought maybe the light switch was the problem as it shorted inside the dash in transportation, but replacement of it didnt fix my problem.

    Any ideas on what and how to troubleshoot beyond that. Looking at the wiring diagram hasn't helped me.

    Thanks 65tang

  2. #2
    Senior Member 390gtconv's Avatar
    Join Date
    Apr 2012
    Location
    Chester, NH
    Posts
    1,786
    Need more info. You say "it's the running lights" then say when you unplug feed from brake switch they go off. Doesn't make sense as those are 2 different circuits. I'm gonna guess your problem is "brake lights" not running lights. Brake light circiut goes thru your turn signal switch on steering column. But I'd take a better look at brake switch on pedal. See if pedal moves enough to moves switch. Also switch on pedal could be bad. You can take switch off and check with meter, pressed switch should close circuit making lights go on.
    Last edited by 390gtconv; 07-05-2013 at 11:22 AM.

  3. #3
    Junior Member
    Join Date
    Jul 2012
    Location
    Hampton
    Posts
    5

    Thanks ill try that

    Hi,
    Thanks for the quick reply. ill try that, but didn't think it was my issue because when i pressed on the break they would get brighter.

  4. #4
    Junior Member
    Join Date
    Jul 2012
    Location
    Hampton
    Posts
    5
    I also should note that the instrument cluster lights are all out too.

  5. #5
    Senior Member 390gtconv's Avatar
    Join Date
    Apr 2012
    Location
    Chester, NH
    Posts
    1,786
    Quote Originally Posted by 65tang View Post
    I also should note that the instrument cluster lights are all out too.
    Sounds like 2 diff problems. For dash lights I'd check fuse panel, assuming every thing behind dash cluster is plugged in and bulbs ok. Electrical problems can drive people crazy but not that hard to sort on older cars, just take your time.

  6. #6
    Junior Member
    Join Date
    Jul 2012
    Location
    Hampton
    Posts
    5

    Tail lights fixed, still no instrument

    Hi,

    Thanks for the help. The break light switch had mettle shavings in it from a dash repair. I replaced the switch and kept the old one as I think I can clean it up. Now I have no instrument backlight. Light switch smoked but dint blow a fuse.

  7. #7
    Senior Member 390gtconv's Avatar
    Join Date
    Apr 2012
    Location
    Chester, NH
    Posts
    1,786
    Welcome.
    Now dash lights come from h/l switch which btw has internal circuit breaker that resets itself. I'd either replace h/l switch (assuming all plugs at dash are good and connected as well as ground wire for cluster and bulbs ok) or take a look at h/l switch in particuliar the white ceramic disk which controls dash and interior brightness. Sometimes contact on switch to disk get dirty and corroded. Try cleaning with emery paper or just replace switch.

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts